Crash at open

Photo annotation and geotagging

Crash at open

Postby sgowtham » Sun Jun 19, 2011 7:51 am

Since yesterday (most probably after I did 'AcroProUpd830' update), every time I try opening PhotoLinker, it crashes. I have the links crash report as well as the Adobe Acrobat Update logs below.

http://sgowtham.net/misc/bugs/photolinker_error.txt
http://sgowtham.net/misc/bugs/AcroProUpd830_all0.log
http://sgowtham.net/misc/bugs/AcroProUpd830_all1.log
http://sgowtham.net/misc/bugs/AcroProUpd830_all2.log


I use

Mac OS X v10.6.7
Apple MacBook Pro, 2.2 GHz Intel Core 7
8 GB RAM (1333 MHz DDR3)

If any of you have a solution for this, I'd greatly appreciate it.

Best regards,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby Jeffrey_Early » Sun Jun 19, 2011 7:06 pm

Weird crash.

First, I would try deleting the application preferences located in
~/Library/Preferences/com.earlyinnovations.PhotoLinker
If that works, try opening the Geotagging Console (because that's what it's crashing on).

Second, I would try downloading a new copy of PhotoLinker. It's having trouble with one of the built-in resources, so it's not unreasonable to think that a fresh copy won't make a difference.

Give that a shot and let me know how it goes,
Jeffrey
Jeffrey_Early
 
Posts: 205
Joined: Wed Sep 24, 2008 1:55 pm

Re: Crash at open

Postby sgowtham » Sun Jun 19, 2011 8:52 pm

Thank you for your response. I tried

1. removing the '~/Library/Preferences/com.earlyinnovations.PhotoLinker' file, re-started my mac and re-opened PhotoLinker - same result, it crashed at launch

2. removed the current copy of PhotoLinker app, downloaded a fresh copy from the official website - same result as well, it crashed at launch

3. I also removed the Adobe Acrobat Professional completely (update to which, I thought, was the cause of this problem) and repeated #1 & #2 - same result again, it crashed at launch.

Crash report is here:

http://sgowtham.net/misc/bugs/photolinker_error_01.txt

Now, I don't see '~/Library/Preferences/com.earlyinnovations.PhotoLinker'. I'd appreciate any other tip/trick to get this working again.

Best regards,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby Jeffrey_Early » Sun Jun 19, 2011 9:32 pm

Since loading the nib seems to be the problem, maybe it's related to language settings. Could you try making English the primary language, if it's not already, and see if that makes a difference? Actually -- maybe also try making the "Formats" set to "Region: United States" as well (these are all under the Language & Text settings). We had a crash a while back related to formatting, so if you're defaulting to something else I wouldn't be surprised if that's causing the crash.

OTOH, none of this makes sense with your upgrade timing.

Jeffrey
Jeffrey_Early
 
Posts: 205
Joined: Wed Sep 24, 2008 1:55 pm

Re: Crash at open

Postby sgowtham » Sun Jun 19, 2011 9:46 pm

I tried both of these (they were already set to the suggested values) and below are the links to screenshots:

http://sgowtham.net/misc/bugs/mac_language-text_00.png
http://sgowtham.net/misc/bugs/mac_language-text_01.png

and PhotoLinker still crashes at launch:

http://sgowtham.net/misc/bugs/photolinker_error_02.txt

Best,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby sgowtham » Sun Jun 19, 2011 11:01 pm

I gave it one more try:

1. Removed the PhotoLinker app
2. Emptied trash
3. Rebooted the machine
4. Downloaded a fresh copy of PhotoLinker app

Still crashes at launch. However, I see different errors (please see links to log files below) that are leading to crash.

http://sgowtham.net/misc/bugs/photolinker_error_03.txt
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '-[NSViewController loadView] could not load the "GLMultipleSelectionOptionsHUD" nib.'

http://sgowtham.net/misc/bugs/photolinker_error_04.txt
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '-[NSViewController loadView] could not load the "GLThumbnailView" nib.'

http://sgowtham.net/misc/bugs/photolinker_error_05.txt
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '-[NSViewController loadView] could not load the "GLPhotoBrowser" nib.'

http://sgowtham.net/misc/bugs/photolinker_error_06.txt
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '-[NSViewController loadView] could not load the "GLThumbnailView" nib.'

http://sgowtham.net/misc/bugs/photolinker_error_07.txt
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '-[NSViewController loadView] could not load the "GLMultipleSelectionOptionsHUD" nib.'


Best,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby sgowtham » Tue Jun 21, 2011 6:48 pm

Ok - I tried to reproduce the same behavior on another machine. On my older MacBook Pro, Adobe Acrobat prompted that I update to v8.3.0 - update went smooth. And PhotoLinker application opened just fine after this update, confirming your findings (that timing of Adobe Update had nothing to do with the behavior of PhotoLinker on my newer MacBook Pro).

I rebooted the old MacBook Pro just for kicks and PhotoLinker still opens just fine.

However, it still continues to crash at launch on my new MacBook Pro.

Best,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby sgowtham » Tue Jun 21, 2011 7:11 pm

Wondering if this problem was just isolated to my account on this machine, I created a new account (standard user, no admin powers) on my new MacBook Pro - except for an initial warning (that 'filename is invalid') every time I try opening it, PhotoLinker does open successfully - lets me add tracks and tag photos as well.

So, it does look like problem is somewhere just within my account (which has admin powers). Any thoughts/help please?

Best,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Re: Crash at open

Postby Brian_Curtis » Tue Jun 21, 2011 8:27 pm

Did you try deleting the ~/Library/Application Support/EarlyInnovations folder? Deleting that folder will delete your track database.
Brian_Curtis
Site Admin
 
Posts: 67
Joined: Wed Sep 24, 2008 11:21 am

Re: Crash at open

Postby sgowtham » Wed Jun 22, 2011 3:07 am

Yup, that did the trick. After my last reply, here's all I did:

1. Disk Utility --> Verify & Repair Permissions
2. Reboot
3. Delete the ~/Library/Application Support/EarlyInnovations folder
4. Delete the ~/Library/Application Support/Cache/EarlyInnovations folder

PhotoLinker started up like good ole days. Thank you!

Also, I'm not too worried about losing the tracks within PhotoLinker - I keep a a GPX file, one per calendar day, in a separate folder (details here: http://sgowtham.net/blog/2009/02/12/php ... -in-mysql/) and can import them back into the application.

Thanks again for your time and help with this.

Best,
Gowtham

--
Gowtham
http://sgowtham.net/
sgowtham
 
Posts: 9
Joined: Sun Jun 19, 2011 7:39 am

Next

Return to PhotoLinker

Who is online

Users browsing this forum: No registered users and 0 guests

cron